makedeb
A posix script to find and watch youtube videos from the terminal Without API
Viewing /PKGBUILD
.
Click here to go back to the Git tree for ytfzf.
# Maintainer: only_vip <onlyme_vip@protonmail.com>
pkgname=ytfzf
pkgver='2.6.2'
pkgrel=1
pkgdesc="A posix script to find and watch youtube videos from the terminal Without API"
arch=('any')
url="https://github.com/pystardust/ytfzf"
license=('GPL3')
depends=('jq' 'mpv')
provides=('ytfzf')
conflicts=('ytfzf')
# replaces=('ytfzf')
makedepends=('make')
optdepends=(
'dmenu: use dmenu for search prompts and results'
'rofi: use rofi for search prompts and results'
'fzf: use fzf for results.Get it from the MPR as thumbnails works only with the latest fzf version'
'ueberzug: thumbnails image preview '
'yt-dlp: to download videos'
)
source=("https://github.com/pystardust/ytfzf/archive/v${pkgver}.tar.gz")
sha512sums=("9c2d6d6fbd6a21385531523401c113b681d8fd3e3bc0f6566730e0de55a4e70a4d86bebced7cdf472cb145cc1247b79b25ba502ec7a79aee0d89ad816ba434ef")
package() {
cd "$srcdir/${pkgname}-${pkgver}"
make PREFIX="/usr" \
DESTDIR="$pkgdir/" \
install "doc" "addons"
}