makedeb
yq is a portable command-line YAML, JSON, XML, CSV and properties processor
Viewing /PKGBUILD
.
Click here to go back to the Git tree for yq.
# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
repology_pkgname=yq-mikefarah
pkgname=yq
pkgver=4.34.1
pkgrel=1
epoch=1
pkgdesc="yq is a portable command-line YAML, JSON, XML, CSV and properties processor"
arch=(amd64 arm64 arm32 i386 i686)
url="https://mikefarah.gitbook.io/yq/"
license=('MIT')
makedepends=(golang-go gzip pandoc)
source=(
"https://github.com/mikefarah/$pkgname/archive/refs/tags/v$pkgver.tar.gz"
)
sha256sums=('69ff6f8bbb5f9eff5ccb537597740d24200db201b2709e442ae5effdbcb8ff9d')
build() {
cd "yq-$pkgver"
go build
scripts/generate-man-page-md.sh
scripts/generate-man-page.sh
gzip -f yq.1
}
package() {
cd "yq-$pkgver"
install -D yq "${pkgdir}/usr/bin/yq"
install -D yq.1.gz "${pkgdir}/usr/share/man/man1/yq.1.gz"
}