makedeb


yq 1:4.43.1-1


yq is a portable command-line YAML, JSON, XML, CSV and properties processor

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for yq.

# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
repology_pkgname=yq-mikefarah
pkgname=yq
pkgver=4.43.1
pkgrel=1
epoch=1
pkgdesc="yq is a portable command-line YAML, JSON, XML, CSV and properties processor"
arch=(amd64 arm64 arm32 i386 i686)
url="https://mikefarah.gitbook.io/yq/"
license=('MIT')
makedepends=(golang-go gzip pandoc)
source=("https://github.com/mikefarah/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('e5581d28bae2bcdf70501dfd251233c592eb3e39a210956ee74965b784435d63')

build() {
  cd "yq-$pkgver"
  go build
  scripts/generate-man-page-md.sh
  scripts/generate-man-page.sh
  gzip -f yq.1
}

package() {
  cd "yq-$pkgver"
  install -D yq "${pkgdir}/usr/bin/yq"
  install -D yq.1.gz "${pkgdir}/usr/share/man/man1/yq.1.gz"
}