makedeb


wlrctl-git 0.2.2-1


Command line utility for miscellaneous wlroots Wayland extensions

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for wlrctl-git.

# Maintainer: Maor Kadosh <fun.iron8147@avocadosh.xyz>
_pkgname=wlrctl
pkgname=wlrctl-git
pkgrel=1
pkgver="0.2.2"
pkgdesc='Command line utility for miscellaneous wlroots Wayland extensions'
arch=('any')
makedepends=('ninja-build' 'meson' 'scdoc')
url='https://git.sr.ht/~brocellous/wlrctl'

source=("git+${url}")
sha256sums=('SKIP')

pkgver() {
    cd "$_pkgname"
    git describe --tags | sed 's/^v//'
}

package() {
    cd "$_pkgname"
    meson setup --prefix="${pkgdir}/usr/local" build
    ninja -C build install
}

# vim: set sw=4 expandtab: