makedeb
Futuristic anti-gravity racing game. A re-implementation of the 1995 game wipEout.
Viewing /PKGBUILD
.
Click here to go back to the Git tree for wipeout-git.
# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
pkgname=wipeout-git
_pkgname=wipeout
_srcname=wipeout-rewrite
pkgver=0.r68.90702ce
pkgrel=1
pkgdesc="Futuristic anti-gravity racing game. A re-implementation of the 1995 game wipEout."
arch=('amd64')
url="https://phoboslab.org/log/2023/08/rewriting-wipeout"
license=('abandonware')
# sdl
makedepends=('git' 'libsdl2-dev' 'libglew-dev')
depends=("libsdl2-2.0-0" "libglew2.2")
# sokol
#makedepends=('git' 'libx11-dev' 'libxcursor-dev' 'libxi-dev' 'libasound2-dev')
#depends=('libx11-6' 'libxcursor1' 'libxi6' 'libasound2')
provides=('wipeout')
conflicts=('wipeout')
# alternate data link, "makedeb -g" for the checksum
#https://archive.org/download/wipeout-data.tar/wipeout-data.tar.zst
source=("git+https://github.com/phoboslab/wipeout-rewrite"
"https://phoboslab.org/files/wipeout-data-v01.zip"
"${_pkgname}.png::https://static.wikia.nocookie.net/wipeout/images/f/fa/F3600.png/revision/latest/scale-to-width-down/350")
b2sums=('SKIP'
'072987a4b532ba4a00e78d721719035bc763774f6b0f2c3de003b6597436618c6b8757f6ca8417d5db21720abfa0f49c13527963fd9cf797691cde419cd61ea7'
'ae98c5d030abe7299eece616f645583f91a5c906c009c747c3d93c584edc081f0478f449a59e1395e889b7057f4e3b56e326abb9a932eab8dd1ac66dc4c90b5b')
options=('!strip')
pkgver() {
cd ${srcdir}/${_srcname}
printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd ${srcdir}/${_srcname}
# bug DPATH_ASSETS missing intro, compilling with it but will not use
# sdl
make USER_CFLAGS="-DPATH_ASSETS=/usr/share/games/" DEBUG=false USE_GLX=false RENDERER=GL sdl
# sokol
#make USER_CFLAGS="-DPATH_ASSETS=/usr/share/games/" DEBUG=false USE_GLX=false RENDERER=GL sokol
}
package() {
cd ${srcdir}/${_srcname}
#Creating Directories
install -m755 -d $pkgdir/usr/{games,libexec/${_pkgname},share/{doc/${_pkgname},games,pixmaps,applications}}
# Installing
install -D -m755 $srcdir/${_srcname}/wipegame $pkgdir/usr/libexec/${_pkgname}/${_pkgname}-bin
# install -D -m755 $srcdir/${_srcname}/wipegame $pkgdir/usr/games/${_pkgname}
cp -R $srcdir/${_pkgname} $pkgdir/usr/share/games/
install -D -m644 $srcdir/${_srcname}/README.md $pkgdir/usr/share/doc/${_pkgname}/readme
install -D -m644 $srcdir/${_pkgname}.png $pkgdir/usr/share/pixmaps/$_pkgname.png
# linking
ln -s /usr/share/games/${_pkgname} $pkgdir/usr/libexec/${_pkgname}/
# Adjustments
rm $pkgdir/usr/share/games/${_pkgname}/game_data_goes_here.txt
# Desktop file
echo "[Desktop Entry]
Type=Application
Version=1.0
Encoding=UTF-8
Name=wipEout
Name[en]=wipEout
GenericName=A re-implementation of the 1995 game wipEout.
GenericName[en]=A re-implementation of the 1995 game wipEout.
Comment=Futuristic anti-gravity racing game.
Comment[en]=Futuristic anti-gravity racing game.
Icon=wipeout
Exec=wipeout
Terminal=false
StartupNotify=false
Categories=Application;Game" > $pkgdir/usr/share/applications/wipeout.desktop
# Wrapper script
echo "#!/bin/sh
cd \"/usr/libexec/${_pkgname}\"
exec ./${_pkgname}-bin" > $pkgdir/usr/games/wipeout
chmod 755 $pkgdir/usr/games/wipeout
}