makedeb
A tool to help set up WireGuard based networks. Currently, it generates configurations for peers according to a single configuration file.
Viewing /PKGBUILD
.
Click here to go back to the Git tree for wg-make-bin.
# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
pkgver_="1.0.0-alpha" # the "-" in the name is considered invalid by makedeb,
# so we store this in a separate var for now, until wg-make is taken out of alpha
pkgname="wg-make-bin"
pkgver=$(echo $pkgver_ | sed 's/-//')
pkgrel=1
epoch=1
pkgdesc="A tool to help set up WireGuard based networks. Currently, it generates configurations for peers according to a single configuration file."
arch=(amd64)
url="https://github.com/tevino/wg-make"
license=('Apache 2.0')
source=(
"https://github.com/tevino/wg-make/releases/download/v${pkgver_}/wg-make_${pkgver_}_Linux_x86_64.tar.gz"
)
sha256sums=(
"449a69f1acd67f00f9663073fd3fd50c2d6b00ff18c41af6981aa3af2c57e166"
)
package() {
install -D wg-make "$pkgdir/usr/bin/wg-make"
}