makedeb
Vulkan 2D graphics library following the Cairo API
Viewing /PKGBUILD
.
Click here to go back to the Git tree for vkvg.
# Maintainer: Jean-Philippe Bruyère <jp_bruyere@hotmail.com>
pkgname=vkvg
pkgver=0.3.0
pkgrel=1
pkgdesc='Vulkan 2D graphics library following the Cairo API'
arch=(x86_64)
url='https://github.com/jpbruyere/vkvg'
license=('MIT')
makedepends=('cmake' 'git' 'xxd' 'libvulkan-dev' 'libfontconfig-dev' 'libfreetype-dev' 'libharfbuzz-dev')
#'shaderc'
depends=( 'libvulkan1' 'libfontconfig1' 'libfreetype6' 'libharfbuzz0b' )
optdepends=('libglfw3-dev: enable build tests')
source=("$pkgname-$pkgver"::"git+https://github.com/jpbruyere/vkvg#tag=v$pkgver-beta")
sha256sums=('SKIP')
options=(!strip)
prepare() {
cd $pkgname-$pkgver
git submodule update --init --recursive
mkdir -p build
}
build() {
cd $pkgname-$pkgver/build
cmake .. -DCMAKE_BUILD_TYPE=Release -DVKVG_BUILD_TESTS=false
cmake --build .
}
package() {
cd $pkgname-$pkgver
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd build
make DESTDIR="$pkgdir/" install
}