makedeb
A graphical user interface tool for configuration of the rxvt-unicode terminal emulator.
Viewing /PKGBUILD
.
Click here to go back to the Git tree for urxvt-config-git.
# Maintainer: only_vip <onlyme_vip@protonmail.com>
pkgname=urxvt-config-git
_gitname=URXVTConfig
pkgver=1f5140f92017.11.30
pkgrel=2
pkgdesc="A graphical user interface tool for configuration of the rxvt-unicode terminal emulator."
arch=('amd64')
url="https://github.com/daedreth/URXVTConfig"
license=('LGPL-3.0')
depends=('libqt5charts5')
#buster_depends=(${depends[@]})
#focal_depends=(${depends[@]})
#groovy_depends=(${depends[@]} )
#hirsute_depends=(${depends[@]})
makedepends=('qt5-qmake' 'libqt5charts5-dev')
optdepends=()
conflicts=($pkgname)
provides=($pkgname)
# replaces=($pkgname)
source=("${_gitname}::git+https://github.com/daedreth/${_gitname}.git#branch=master")
md5sums=("SKIP")
pkgver() {
cd "${srcdir}/${_gitname}"
_always=$(git describe --always | sed -e 's:-:.:g' -e 's:vNext::') # always is mobile, and switches between numbers and letters, can't use it for versioning
_commits=$(git rev-list --count HEAD | sed 's:-:.:g') # total commits is the most sane way of getting incremental pkgver
_date=$(git log -1 --date=short --pretty=format:%cd)
printf "%s%s%s\n" "${_commits}" "${_always}" "${_date}" | sed -e 's:-:.:g' -e 's:_:.:g'
}
package() {
cd "${srcdir}/${_gitname}"
'/usr/lib/x86_64-linux-gnu/qt5/bin/qmake' 'source/URXVTConfig.pro'
make DESTDIR="${pkgdir}"
install -Dm755 urxvtconfig "$pkgdir/usr/bin/urxvtconfig"
install -D -m 644 "source/urxvtconfig.desktop" "$pkgdir/usr/share/applications/urxvtconfig.desktop"
}