makedeb
The Cloud Native Application Proxy
Viewing /PKGBUILD
.
Click here to go back to the Git tree for traefik-bin.
# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
pkgname=traefik-bin
pkgver=2.9.10
pkgrel=1
epoch=1
pkgdesc="The Cloud Native Application Proxy"
arch=(amd64)
url="https://traefik.io/"
license=('MIT')
backup=(
"/etc/traefik/traefik.yml"
"/etc/systemd/system/traefik.service"
)
source=(
"https://github.com/traefik/traefik/releases/download/v$pkgver/traefik_v${pkgver}_linux_amd64.tar.gz"
"traefik.service"
"traefik.yml"
)
sha256sums=(
"a6cf63c4fcbef9723701997c6d0692eb047cde4b62367e3b84498d144442d743"
SKIP
SKIP
)
postinst="traefik.postinst"
prerm="traefik.prerm"
postrm="traefik.postrm"
package() {
install -D traefik "$pkgdir/usr/bin/traefik"
install -D traefik.yml "$pkgdir/etc/traefik/traefik.yml"
install -D traefik.service "$pkgdir/etc/systemd/system/traefik.service"
}