makedeb
Upgrade all the things
Viewing /PKGBUILD
.
Click here to go back to the Git tree for topgrade.
# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=topgrade
pkgver=12.0.2
pkgrel=1
pkgdesc='Upgrade all the things'
arch=('any')
makedepends=('cargo')
url='https://topgrade-rs.github.io'
license=('GPL3')
source=("https://github.com/topgrade-rs/topgrade/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('3bd71c8ee3f38fdddc1f9475f1c46d4949ce2f016e26dda71ac3c723e7488c57')
build() {
cd "${pkgname}-${pkgver}/"
cargo build --release
}
package() {
cd "${pkgname}-${pkgver}/"
install -Dm 755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}
# vim: set sw=4 expandtab: