makedeb
tmux is a terminal multiplexer
Viewing /PKGBUILD
.
Click here to go back to the Git tree for tmux.
# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
pkgname=tmux
pkgver=3.5a
pkgrel=1
epoch=1
pkgdesc="tmux is a terminal multiplexer"
arch=(amd64 arm64 arm32 i386 i686)
url="https://tmux.github.io"
license=('ISC')
depends=(libevent-core-2.1-7)
makedepends=(build-essential libevent-dev libncurses-dev flex bison)
source=(
"https://github.com/$pkgname/$pkgname/releases/download/$pkgver/tmux-$pkgver.tar.gz"
)
noextract=()
sha256sums=('16216bd0877170dfcc64157085ba9013610b12b082548c7c9542cc0103198951')
validpgpkeys=()
build() {
cd "$pkgname-$pkgver"
./configure --prefix="/usr" && make
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}