makedeb
tmux is a terminal multiplexer
Viewing /PKGBUILD
.
Click here to go back to the Git tree for tmux.
# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
pkgname=tmux
pkgver=3.5
pkgrel=1
epoch=1
pkgdesc="tmux is a terminal multiplexer"
arch=(amd64 arm64 arm32 i386 i686)
url="https://tmux.github.io"
license=('ISC')
depends=(libevent-core-2.1-7)
makedepends=(build-essential libevent-dev libncurses-dev flex bison)
source=(
"https://github.com/$pkgname/$pkgname/releases/download/$pkgver/tmux-$pkgver.tar.gz"
)
noextract=()
sha256sums=('2fe01942e7e7d93f524a22f2c883822c06bc258a4d61dba4b407353d7081950f')
validpgpkeys=()
build() {
cd "$pkgname-$pkgver"
./configure --prefix="/usr" && make
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}