makedeb
Manage multiple Telegram Desktop account
Viewing /PKGBUILD
.
Click here to go back to the Git tree for tmulti.
# Maintainer: andrew-ld <andrew-ld@protonmail.com>
pkgname=tmulti
pkgver=16.5984
pkgrel=2
pkgdesc="Manage multiple Telegram Desktop account"
arch=('any')
url="https://github.com/andrew-ld/tmulti"
license=("GPL3")
depends=("telegram-desktop" "libqt5core5a" "libqt5gui5" "libqt5widgets5")
provides=("tmulti")
makedepends=("git" "make" "gcc" "qtbase5-dev" "qt5-qmake" "imagemagick")
source=("tmulti::git+https://github.com/andrew-ld/tmulti" "tmulti.desktop")
sha1sums=("SKIP" "42425bb1b5c33d5aab7ca8236a2766aac63fa1ab")
prepare() {
cd "$srcdir/tmulti"
qmake .
make
convert "$srcdir/tmulti/res/icon.png" "$srcdir/tmulti.png"
}
package() {
cd "$srcdir/tmulti"
INSTALL_ROOT=$srcdir make install
install -Dm755 "$srcdir/opt/tmulti/bin/tmulti" -t "$pkgdir/usr/bin/"
install -Dm644 "$srcdir/tmulti.png" -t "$pkgdir/usr/share/pixmaps/"
install -Dm644 "$srcdir/tmulti.desktop" -t "$pkgdir/usr/share/applications/"
}