makedeb


tf2-bot-kicker-gui-bin 1.3.0-1


An automatic Bot Detector and kicking software for TF2

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for tf2-bot-kicker-gui-bin.

# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>

pkgname='tf2-bot-kicker-gui-bin'
_gitname='tf2-bot-kicker-gui'
provides=('tf2-bot-kicker-gui')
pkgver='1.3.0'
pkgrel='1'
pkgdesc="An automatic Bot Detector and kicking software for TF2"
arch=('x86_64')
license=('MIT')
url='https://github.com/Bash-09/tf2-bot-kicker-gui'
source=("${url}/releases/download/v${pkgver}/TF2_Bot_Kicker_Linux.zip"
		"tf2-bot-kicker-gui.png"::"${url}/raw/v${pkgver}/images/logo.png"
		"tf2-bot-kicker-gui.desktop"
		"tf2-bot-kicker-gui.sh")
conflicts=("${_gitname}-git" "${_gitname}")
_confdirectory='/etc/tf2-bot-kicker-gui'
backup=("${_confdirectory}/playerlist.json"
		"${_confdirectory}/regx.txt"
		"${_confdirectory}/settings.json")
b2sums=('fe4a33d3dfd3b622967057811c37082cda13d44a4ceee7332d53348a57d75044604bd014862f947438401f0857b86b263f5cecf515e9a9af1712199944455731'
        '8abac7960e936e9f7ec3d2078248798b03a4ca8af36d40c8c4d439d98d5dc215a116a65585efd52d4cd8ca41b5e6d8b042f6c0e4981eac50f2633563ebcddba0'
        'fe5f85aa659a8e399799b0d56a0cbcfe848311735ca690f53cbdf93c1d09367e9d7b696a6b04a1629820741d98a3b1757c5a7e8fdf6631ee0b1339da2c41d891'
        'bbab5b7be01fb8341bcd8cff48fd281ababb90215cc87efe6d94dee1cc5765af2bb68f186ab850f067fee5c9cf48fac089e6971b746ef64367c076ddb0436c97')


package() {
	# install desktop entry
	install -Dm644 "tf2-bot-kicker-gui.desktop" "${pkgdir}/usr/share/applications/tf2-bot-kicker-gui.desktop"
    install -Dm644 "tf2-bot-kicker-gui.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/tf2-bot-kicker-gui.png"
	# install binaries
	install -Dm755 "tf2-bot-kicker-gui" -t "${pkgdir}/opt/tf2-bot-kicker-gui"
	# install script
	install -d "${pkgdir}/usr/bin"
	install -Dm755 "tf2-bot-kicker-gui.sh" "${pkgdir}/usr/bin/tf2-bot-kicker-gui"
	# create config files
	install -Dm666 "cfg/playerlist.json" -t "${pkgdir}/etc/tf2-bot-kicker-gui"
	install -Dm666 "cfg/regx.txt" -t "${pkgdir}/etc/tf2-bot-kicker-gui"
	touch "${pkgdir}/etc/tf2-bot-kicker-gui/settings.json"
	chmod -R 777 "${pkgdir}/etc/tf2-bot-kicker-gui/"
	# symlink config files to opt
	ln -s "/etc/tf2-bot-kicker-gui" "${pkgdir}/opt/tf2-bot-kicker-gui/cfg"
}