makedeb
MPR in your pocket
Viewing /PKGBUILD
.
Click here to go back to the Git tree for tap.
# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=tap
pkgver=2.0.5
pkgrel=1
pkgdesc="MPR in your pocket"
arch=('any')
depends=('python3' 'python3-requests' 'python3-apt' 'less')
optdepends=('r!bash-completion')
makedepends=('python3-setuptools' 'asciidoctor' 'make')
conflicts=('node-tap')
license=('GPL3')
control_fields=("MPR-Package: ${pkgname}")
postinst="${pkgname}.postinst"
url="https://github.com/hwittenborn/tap"
source=("git+${url}/#tag=v${pkgver}-${pkgrel}")
sha256sums=('SKIP')
prepare() {
cd tap/
make prepare PKGVER="${pkgver}"
}
package() {
cd tap/
make install DESTDIR="${pkgdir}"
}