makedeb


taisei 1.4.2-0


Open source Touhou clone

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for taisei.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: Lukas Weber (AUR) <laochailan web de>
# Contributor: Andrei Alexeyev (AUR) <akari taisei-project org>
# Contributor: cyberpunkrocker (AUR) <l33tmmx gmail com>
# Contributor: carstene1ns (AUR) <arch carsten-teibes de> - http://git.io/ctPKG

pkgname=taisei
pkgver=1.4.2
pkgrel=0
pkgdesc="Open source Touhou clone"
arch=('i386' 'amd64')
url="https://taisei-project.org/"
license=('MIT')
makedepends=('meson' 'python3-docutils' 'python3-zstandard' 'libopengl-dev' 'libcglm-dev' 
 'libsdl2-mixer-dev' 'libfreetype-dev' 'libpng-dev' 'libwebp-dev' 'libzip-dev' 'libzstd-dev' 'libopusfile-dev' zlib1g-dev)
optmakedepends=('gamemode-dev' 'openssl')
depends=('libopengl0' 'libcglm0' 'libsdl2-mixer-2.0-0' 'libfreetype6' 'libpng16-16'
 'libwebp7' 'libzip4' 'hicolor-icon-theme' 'libopusfile0' 'zlib1g' 'libzstd1')
optdepends=('gamemode')
# not tested on bullseye
bulleye_depends=('libopengl0' 'libcglm0' 'libsdl2-mixer-2.0-0' 'libfreetype6' 'libpng16-16'
 'libwebp6' 'libzip4' 'hicolor-icon-theme' 'libopusfile0' 'zlib1g' 'libzstd1')
source=("https://github.com/taisei-project/taisei/releases/download/v$pkgver/taisei-$pkgver.tar.xz")
b2sums=('382e6e02013573f4218a073ad9d19cd128f0b4366d3f3f586e8ab4de9a5948ffedd13a22cefc9a8af04cccd2cf0205c9d6c738b125fd332b363606acd5938e4a')

build() {
  cd $pkgname-$pkgver
  meson build --prefix=/usr --bindir games --datadir share/games
  ninja -C build 
}

package() {
  cd $pkgname-$pkgver
  DESTDIR="$pkgdir" ninja install -C build

  mv "$pkgdir"/usr/share/games/doc "$pkgdir"/usr/share/
  mv "$pkgdir"/usr/share/games/applications "$pkgdir"/usr/share/
  mv "$pkgdir"/usr/share/games/icons "$pkgdir"/usr/share/
  mv "$pkgdir"/usr/share/games/mime "$pkgdir"/usr/share/
  install -Dm644 README.rst "$pkgdir"/usr/share/doc/$pkgname/readme
}