makedeb


surgescript 0.5.6.1-1


SurgeScript is a scripting language for games.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for surgescript.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: José Rebelo (AUR) <joserebelo at outlook dot com>

pkgname=surgescript
pkgver=0.5.6.1
pkgrel=1
pkgdesc='SurgeScript is a scripting language for games.'
arch=('i386' 'amd64' 'arm' 'armel' 'armhf' 'arm64')
url='https://github.com/alemart/surgescript'
license=('Apache-2.0')
makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/alemart/surgescript/archive/v$pkgver.tar.gz")
b2sums=('965715523893781b5c63851d6cd1cc3a4842451807a96b85377a166d4190e5d7cbe83f65b2086b1ed8b2956cf89dd188ddb6135f30b778f1b1d50d9dc9e3028a')

build() {
  cd $pkgname-$pkgver
  mkdir -p build && cd build
  cmake -DCMAKE_INSTALL_PREFIX=/usr ..
  make -j $(nproc)
}

package() {
  cd $pkgname-$pkgver/build
  make DESTDIR="$pkgdir/" install
  cd ..
  install -Dm644 "LICENSE" "$pkgdir/usr/share/doc/$pkgname/license"
  install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/readme"
  install -Dm644 "CHANGES.md" "$pkgdir/usr/share/doc/$pkgname/changelog"
  gzip "$pkgdir/usr/share/doc/$pkgname/changelog"
}