makedeb
SurgeScript is a scripting language for games.
Viewing /PKGBUILD
.
Click here to go back to the Git tree for surgescript.
# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: José Rebelo (AUR) <joserebelo at outlook dot com>
pkgname=surgescript
pkgver=0.6.1
pkgrel=0
pkgdesc='SurgeScript is a scripting language for games.'
arch=('i386' 'amd64' 'arm' 'armel' 'armhf' 'arm64')
url='https://github.com/alemart/surgescript'
license=('Apache-2.0')
makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/alemart/surgescript/archive/v$pkgver.tar.gz")
b2sums=('4942f2befb143bbdd2637323afe81c5ad43548f63f8f7b39f8c0ae8a1772d14ef75af9e0d8a5c460b903d8a8320e44d82127165df666a65cf3a0307e1bf7078c')
build() {
cd $pkgname-$pkgver
mkdir -p build && cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make -j $(nproc)
}
package() {
cd $pkgname-$pkgver/build
make DESTDIR="$pkgdir/" install
cd ..
install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/readme"
install -Dm644 "CHANGES.md" "$pkgdir/usr/share/doc/$pkgname/changelog"
ln -s /usr/share/common-licenses/Apache-2.0 "$pkgdir/usr/share/doc/$pkgname/"
gzip "$pkgdir/usr/share/doc/$pkgname/changelog"
}