makedeb
An opinionated code formatter for Lua, written in Rust (binary release)
Viewing /PKGBUILD
.
Click here to go back to the Git tree for stylua-bin.
# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
pkgname=stylua-bin
pkgver=2.0.2
pkgrel=1
epoch=1
pkgdesc="An opinionated code formatter for Lua, written in Rust (binary release)"
arch=('amd64')
url="https://github.com/JohnnyMorganz/StyLua"
license=('MIT')
provides=('stylua')
conflicts=('stylua')
extensions=('zipman')
source=("stylua-${pkgver}.zip::https://github.com/JohnnyMorganz/StyLua/releases/download/v${pkgver}/stylua-linux-x86_64.zip")
sha256sums=('ee9f8f9ba7c19079809d017a5d3f265a9575d1313c0fd24562cbabb99ed26f4f')
package() {
cd "${srcdir}"
install -Dm755 "stylua" "${pkgdir}/usr/bin/stylua"
}