makedeb


starship 1.10.2-1


The minimal, blazing-fast, and infinitely customizable prompt for any shell!

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for starship.

# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=starship
pkgver=1.10.2
pkgrel=1
pkgdesc='The minimal, blazing-fast, and infinitely customizable prompt for any shell!'
arch=('any')
makedepends=('cargo')
url='https://starship.rs'

source=("${pkgname}-${pkgver}::git+https://github.com/starship/starship/#tag=v${pkgver}")
sha256sums=('SKIP')

build() {
    cd "${pkgname}-${pkgver}/"
    cargo build --release --all-features
}

package() {
    cd "${pkgname}-${pkgver}/"
    install -Dm 755 target/release/starship "${pkgdir}/usr/bin/starship"
    target/release/starship completions bash | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/starship"
}

# vim: set sw=4 expandtab: