makedeb
collection of various tools using ssh
Viewing /PKGBUILD
.
Click here to go back to the Git tree for ssh-tools.
# Maintainer: Sven Wick <sven.wick@gmx.de>
pkgname=ssh-tools
pkgver=1.8
pkgrel=1
pkgdesc="collection of various tools using ssh"
arch=("any")
url="https://codeberg.org/vaporup/ssh-tools"
license=("GPL")
depends=("openssh-client")
optdepends=("colordiff: colors for ssh-diff")
makedepends=("help2man")
changelog=
source=("https://codeberg.org/vaporup/${pkgname}/archive/v${pkgver}.tar.gz")
md5sums=("10ca72357514b1be61afdd8b81a3b866")
build() {
cd "$pkgname"
mkdir -p "man"
help2man \
-n "check if host is reachable using ssh_config" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-ping.1 \
./ssh-ping
help2man \
-n "shows version of the SSH server you are connecting to" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-version.1 \
./ssh-version
help2man \
-n "diff a file over SSH" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-diff.1 \
./ssh-diff
help2man \
-n "get some facts about the remote system" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-facts.1 \
./ssh-facts
help2man \
-n "prints server host keys in several formats" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-hostkeys.1 \
./ssh-hostkeys
help2man \
-n "shows validity and information of SSH certificates" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-certinfo.1 \
./ssh-certinfo
help2man \
-n "prints keys in several formats" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-keyinfo.1 \
./ssh-keyinfo
help2man \
-n "enforces password authentication" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-force-password.1 \
./ssh-force-password
help2man \
-n "quickly echo path to use for scp, rsync" \
-S SSH-TOOLS \
-N \
--version-string " " \
-o man/ssh-pwd.1 \
./ssh-pwd
pod2man \
-r SSH-TOOLS \
-c "User Commands" \
./ssh-last \
man/ssh-last.1
}
package() {
cd "$pkgname"
mkdir -p $pkgdir/usr/share/man/man1/
cp man/* $pkgdir/usr/share/man/man1/
mkdir -p $pkgdir/usr/bin/
cp ssh-* $pkgdir/usr/bin/
}