makedeb


spot 0.4.0-1


Native Spotify client for the GNOME desktop

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for spot.

# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=spot
pkgver=0.4.0
pkgrel=1
arch=('any')
depends=(
    'libadwaita-1-0'
    'libasound2'
    'libpulse0'
)
makedepends=(
    'blueprint-compiler'
    'cargo'
    'cmake'
    'libadwaita-1-dev'
    'libpulse-dev'
    'libasound2-dev'
    'meson'
)
pkgdesc='Native Spotify client for the GNOME desktop'
url='https://github.com/xou816/spot'
license=('MIT')

source=("${url}/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('5fde9e07e6b5487587e2dc1b93a6fe88378b7180cfd682a83bc774603f3bc81c')

build() {
    cd "${pkgname}-${pkgver}/"
    meson setup --prefix /usr --libexecdir lib --sbindir bin -D buildtype=release -D offline=false build
    meson compile -C build
}

package() {
    cd "${pkgname}-${pkgver}/"
    meson install -C build --destdir "${pkgdir}"
}

# vim: set sw=4 expandtab: