makedeb
Ocarina of Time OTR game data for SoH, compatoble ROM not included
Viewing /PKGBUILD
.
Click here to go back to the Git tree for soh-otr.
# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# You need a compatible ROM, read more at:
# https://github.com/HarbourMasters/Shipwright
pkgname=soh-otr
pkgver=7.1.1
pkgrel=2
pkgdesc="Ocarina of Time OTR game data for SoH, compatoble ROM not included"
arch=("all")
url="https://shipofharkinian.com/"
license=("proprietary")
makedepends=("soh-otr-exporter")
source=("fille://baserom.z64")
sha256sums=(SKIP)
pkgver() {
apt show soh-bin | grep Version | sed -E 's/.*: (.*)-.*$/\1/'
}
build() {
cd "${srcdir}"
# cleanup
rm -f oot*
export SHIP_HOME="${srcdir}"
export SOHEXTRACTONLY=1
# bug workaround
soh || :
[ -e oot* ] || echo "You need a compatible ROM, read more at:
https://github.com/HarbourMasters/Shipwright"
[ -e oot* ] || exit 1
}
package() {
cd "${srcdir}"
install -Dm644 oot* -t "${pkgdir}/usr/share/games/soh/"
}