makedeb


snapper-rollback-git 1.0-1


Rollback snapper snapshots; https://wiki.archlinux.org/index.php/Snapper#Suggested_filesystem_layout

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for snapper-rollback-git.

# Maintainer: Eric Renfro <psi-jack@linux-help.org>

pkgname=snapper-rollback-git
pkgver=1.0
pkgrel=1
url='https://github.com/jrabinow/snapper-rollback'
pkgdesc='Rollback snapper snapshots; https://wiki.archlinux.org/index.php/Snapper#Suggested_filesystem_layout'
arch=('any')
provides=('snapper-rollback')
conflicts=('snapper-rollback')
license=('GPL-3.0-only')
makedepends=('git')
depends=('coreutils' 'python3' 'btrfs-progs' 'python3-btrfsutil')
backup=('/etc/snapper-rollback.conf')
source=("${pkgname}::git+https://github.com/jrabinow/snapper-rollback")
sha256sums=('SKIP')

pkgver() {
  cd "${pkgname}"
  git describe --long --tags | sed 's/-/.r/;s/-/./'
}

package() {
  cd "${pkgname}"
  install -Dm644 "snapper-rollback.conf" -t "${pkgdir}/etc/"
  install -Dm755 "snapper-rollback.py" "${pkgdir}/usr/sbin/snapper-rollback"
}