makedeb


sea-orm-cli 0.10.3-1


Command line utility for SeaORM

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for sea-orm-cli.

# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
_pkgname=sea-orm
pkgname=sea-orm-cli
pkgver=0.10.3
pkgrel=1
pkgdesc='Command line utility for SeaORM'
arch=('any')
makedepends=('cargo' 'pkg-config')
license=('MIT' 'Apache-2.0')
url='https://www.sea-ql.org/SeaORM'

source=("https://github.com/SeaQL/sea-orm/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('SKIP')

build() {
    cd "${_pkgname}-${pkgver}/${pkgname}/"
    cargo build --release
}

package() {
    cd "${_pkgname}-${pkgver}/${pkgname}/"
    install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
    install -Dm755 "target/release/sea" "${pkgdir}/usr/bin/sea"
}

# vim: set sw=4 expandtab: