makedeb


rpi-imager-deb 1.8.3-2


Raspberry Pi Imaging Utility

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for rpi-imager-deb.

# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
# vim: set sw=2 expandtab:
pkgname=rpi-imager-deb
repology_pkgname=rpi-imager
pkgver=1.8.3
pkgrel=2
pkgdesc='Raspberry Pi Imaging Utility'
arch=(amd64)
depends=(
  'libarchive13'
  'libc6'
  'libcurl3-gnutls'
  'libgcc-s1'
  'libgnutls30'
  'libqt5core5a'
  'libqt5dbus5'
  'libqt5gui5'
  'libqt5network5'
  'libqt5qml5'
  'libqt5widgets5'
  'libstdc++6'
  'qml-module-qtquick2'
  'qml-module-qtquick-controls2'
  'qml-module-qtquick-layouts'
  'qml-module-qtquick-templates2'
  'qml-module-qtquick-window2'
  'qml-module-qtgraphicaleffects'
  'dosfstools'
  'fdisk'
)
provides=('rpi-imager')
conflicts=('rpi-imager')
replaces=('rpi-imager')
extensions=('zipman')
license=('Raspberry Pi Imaging Utility main code license terms')
url='https://github.com/raspberrypi/rpi-imager'

source=("https://github.com/raspberrypi/rpi-imager/releases/download/v${pkgver}/rpi-imager_${pkgver}_amd64.deb")
sha256sums=('85fa2fd34772e23fd2ff6e71c9fd167a0fb15470f96c8d7ed94499b145bf39e3')

build() {
  ar -x "rpi-imager_${pkgver}_amd64.deb"
  tar -xf data.tar.xz
}

package() {
  cp -r "${srcdir}/usr" "${pkgdir}"
}