makedeb


rpi-imager-deb 1.8.5-3


Raspberry Pi Imaging Utility

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for rpi-imager-deb.

# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
# vim: set sw=2 expandtab:
pkgname=rpi-imager-deb
repology_pkgname=rpi-imager
pkgver=1.8.5
pkgrel=3
pkgdesc='Raspberry Pi Imaging Utility'
arch=(amd64)
depends=(
  'libarchive13'
  'libc6'
  'libcurl3-gnutls'
  'libgcc-s1'
  'libgnutls30'
  'libqt5core5a'
  'libqt5dbus5'
  'libqt5gui5'
  'libqt5network5'
  'libqt5qml5'
  'libqt5widgets5'
  'libstdc++6'
  'qml-module-qtquick2'
  'qml-module-qtquick-controls2'
  'qml-module-qtquick-layouts'
  'qml-module-qtquick-templates2'
  'qml-module-qtquick-window2'
  'qml-module-qtgraphicaleffects'
  'dosfstools'
  'fdisk'
)
provides=('rpi-imager')
conflicts=('rpi-imager')
replaces=('rpi-imager')
extensions=('zipman')
license=('Raspberry Pi Imaging Utility main code license terms')
url='https://github.com/raspberrypi/rpi-imager'

source=("https://github.com/raspberrypi/rpi-imager/releases/download/v${pkgver}/rpi-imager_${pkgver}_amd64.deb")
sha256sums=('fcf96ce24f2b852b30a16b243a6592f1f315eb0a19b248efc94d25b34d1167b1')

build() {
  ar -x "rpi-imager_${pkgver}_amd64.deb"
  tar -xf data.tar.zst
}

package() {
  cp -r "${srcdir}/usr" "${pkgdir}"
}