makedeb


python3-pycryptodome-fix 0-0


python3-pycryptodome is actually python3-pycryptodomex in Debian, this fixes the bug

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for python3-pycryptodome-fix.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>

pkgname=python3-pycryptodome-fix
pkgver=0
pkgrel=0
pkgdesc='python3-pycryptodome is actually python3-pycryptodomex in Debian, this fixes the bug'
arch=('all')
license=('PD')
depends=('python3-pycryptodome')
provides=('python3-pycryptodomex')
conflicts=('python3-pycryptodomex')

package() {
  mkdir -p "${pkgdir}/usr/lib/python3/dist-packages"
  ln -Tfs "/usr/lib/python3/dist-packages/Cryptodome" "${pkgdir}/usr/lib/python3/dist-packages/Crypto"
}