makedeb


python3-mov-cli-films-git 1.3.15.r1.ff3ee76-1


A mov-cli v4 plugin for watching films.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for python3-mov-cli-films-git.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
_pkgname=mov-cli-films
pkgname=python3-mov-cli-films-git
pkgver=1.3.15.r1.ff3ee76
pkgrel=1
pkgdesc="A mov-cli v4 plugin for watching films."
arch=('all')
license=('MIT')
depends=('python3-requests')
makedepends=('git' 'python3-build' 'python3-installer' 'python3-wheel')
source=("git+https://github.com/mov-cli/mov-cli-films")
b2sums=(SKIP)
provides=('python3-mov-cli-films')
conflicts=('python3-mov-cli-films')

pkgver() {
  cd "$srcdir/${_pkgname}"
  printf "%s.r%s.%s" "$(grep __version__ film_central/__init__.py | cut -d '"' -f 2)" "$(git rev-list --count HEAD)" "$(git describe --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
}

build(){
  cd "$srcdir/${_pkgname}"
  python3 -m build --no-isolation --wheel
}

package() {
  cd $srcdir/${_pkgname}
  python3 -m installer --destdir="$pkgdir" dist/*.whl #--optimize=1 --skip-build
  # Manual remove local
  mv "$pkgdir/usr/local/"* "$pkgdir/usr/"
  rmdir "$pkgdir/usr/local" 
  #doc
  install -Dm644 "README.md" "$pkgdir/usr/share/doc/$_pkgname/readme"
  install -Dm644 LICENSE "$pkgdir/usr/share/doc/$_pkgname/"
}