makedeb
Collection of common interactive command line user interfaces, based on Inquirer.js
Viewing /PKGBUILD
.
Click here to go back to the Git tree for python3-inquirer.
# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: gilcu3 (AUR) < gilcu3 at gmail dot com >
# Contributor: Luis Martinez (AUR) <luis dot martinez at disroot dot org>
# Contributor: KokaKiwi (AUR) <kokakiwi+aur@kokakiwi.net>
pkgname=python3-inquirer
_pkgname=python-inquirer
pkgver=3.4.0
pkgrel=0
pkgdesc="Collection of common interactive command line user interfaces, based on Inquirer.js"
arch=('all')
url="https://github.com/magmax/${_pkgname}"
license=('MIT')
depends=('python3-blessed' 'python3-editor' 'python3-readchar')
makedepends=('python3-build' 'python3-installer' 'python3-poetry-core' 'python3-wheel')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
b2sums=('4506c041c4ffd2d0aa9cd5f4643390b4ce0e29b8d5655c9956b0c56a7e230b5c12ea7025b72d4b6627b96c2a1eaa4f90efd7526ec0f90e9e57c59ef554bf5f28')
build() {
cd "${_pkgname}-${pkgver}"
python3 -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
python3 -m installer --destdir="$pkgdir" dist/*.whl #--optimize=1 --skip-build
# Manual remove local
mv "$pkgdir/usr/local/"* "$pkgdir/usr/"
rmdir "$pkgdir/usr/local"
# wheel BUG
cp -R src/inquirer "$pkgdir"/usr/lib/*/dist-packages/
python3 -m compileall "$pkgdir"/usr/lib/*/dist-packages/inquirer
#doc
install -Dm644 "LICENSE" "$pkgdir/usr/share/doc/$pkgname/LICENSE"
install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/readme"
}