makedeb
An improved Python library to control i3wm
Viewing /PKGBUILD
.
Click here to go back to the Git tree for python3-i3ipc.
# Maintainer: Cristóbal Tapia <crtapia at gmail dot com>
# Contributor: Maxim Baz <$pkgname at maximbaz dot com>
# Contributor: Stick <stick@stma.is>
_name=i3ipc-python
pkgname=python3-i3ipc
pkgver=2.2.1
pkgrel=2
pkgdesc='An improved Python library to control i3wm'
arch=('any')
url="https://github.com/altdesktop/${_name}"
license=('BSD')
conflicts=('i3ipc-python')
replaces=('i3ipc-python')
depends=('python3' 'python3-xlib')
makedepends=('python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/altdesktop/${_name}/archive/v${pkgver}.tar.gz")
sha256sums=('54af180fac6e3e16c65747884ae4479f0df034c45ed02523f8300f98c99eb29e')
build() {
cd "${_name}-${pkgver}"
python3 setup.py build
}
package() {
cd "${_name}-${pkgver}"
python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm755 -t "${pkgdir}/usr/share/doc/${pkgname}/examples" examples/*.py
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}
# vim:set ts=4 sw=4 et: