makedeb


python3-huggingface-hub 0.19.4-0


All the open source things related to the Hugging Face Hub

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for python3-huggingface-hub.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: Butui Hu (AUR) <hot123tea123@gmail.com>
_pkgname=huggingface_hub
pkgname=python3-huggingface-hub
pkgver=0.19.4
pkgrel=0
pkgdesc='All the open source things related to the Hugging Face Hub'
arch=('all')
url='https://github.com/huggingface/huggingface_hub'
license=('Apache2')
depends=(
  python3-filelock
  python3-requests
  python3-tqdm
  python3-yaml
  python3-typing-extensions
  python3-packaging
)
makedepends=(
  python3-setuptools
)

source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/huggingface/huggingface_hub/archive/refs/tags/v${pkgver}.tar.gz")
b2sums=('a43c8542c4a55709c9fb6d69eff20870dc33a7210004f3efcc72e72f97346ca0bf7a9e2cb42cd8cb7dd5e4a819de22a79f0de42a6e553ea8b523d5caeec2ee74')

build() {
  cd "${_pkgname}-${pkgver}"
  python3 setup.py build
}

package() {
  cd "${_pkgname}-${pkgver}"
  python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build --install-layout deb

  install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/readme"
  ln -s "/usr/share/common-licenses/Apache-2.0" "${pkgdir}/usr/share/doc/$pkgname/"
}

# vim:set ts=2 sw=2 et: