makedeb
Python dependency injection framework, inspired by Guice.
Viewing /PKGBUILD
.
Click here to go back to the Git tree for python-injector.
# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>
# AUR Maintainer: Sophie Tauchert <sophie@999eagle.moe>
_pkgname=injector
pkgname=python-${_pkgname}
pkgver=0.19.0
pkgrel=1
pkgdesc="Python dependency injection framework, inspired by Guice."
arch=('any')
url="http://github.com/alecthomas/injector"
license=('BSD')
depends=('python' 'python-typing')
makedepends=('python-setuptools')
provides=()
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
"https://raw.githubusercontent.com/alecthomas/injector/${pkgver}/COPYING")
sha256sums=('3eaaf51cd3ba7be1354d92a5210c8bba43dd324300eafd214e1f2568834a912f'
'567278bc23fa55244f132af7164aa684940c75fa35b19c395899422cb92613ba')
build() {
cd "${_pkgname}-$pkgver"
python setup.py build
}
package() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "${_pkgname}-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}