makedeb
Minecraft launcher with ability to manage multiple instances.
Viewing /PKGBUILD
.
Click here to go back to the Git tree for prismlauncher-git.
# Maintainer: dada513 <dada513@protonmail.com>
# Contributor: Sefa Eyeoglu <conctact@scrumplex.net>
_pkgname=prismlauncher
pkgname=${_pkgname}-git
pkgver=5.0.r0.g41032aa
pkgrel=2
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'amd64')
url="https://github.com/PrismLauncher/PrismLauncher"
license=('GPL3')
depends=('libqt5xml5' 'libqt5core5a' 'libqt5network5' 'libqt5gui5')
provides=('prismlauncher')
conflicts=('prismlauncher' 'polymc')
makedepends=('extra-cmake-modules' 'g++' 'gcc' 'cmake' 'git' 'openjdk-17-jdk' 'zlib1g-dev' 'libgl1-mesa-dev' 'qtbase5-dev' 'qtchooser' 'qt5-qmake' 'qtbase5-dev-tools')
optdepends=('java-runtime=8: support for Minecraft versions < 1.17'
'java-runtime=17: support for Minecraft versions >= 1.17')
source=("git+https://github.com/PrismLauncher/PrismLauncher.git")
#"git+https://github.com/PrismLauncher/libnbtplusplus.git"
#"git+https://github.com/stachenov/quazip.git"
#"git+https://github.com/marzer/tomlplusplus.git"
#"git+https://github.com/gulrak/filesystem.git")
sha256sums=('SKIP')
#'SKIP'
#'SKIP'
#'SKIP'
#'SKIP')
pkgver() {
cd "PrismLauncher"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "PrismLauncher"
git submodule init
# This trick is broken with recent Git version because of a CVE
#git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
#git config submodule.libraries/quazip.url "${srcdir}/quazip"
#git config submodule.libraries/tomlplusplus.url "${srcdir}/tomlplusplus"
#git config submodule.libraries/filesystem.url "${srcdir}/filesystem"
git submodule update
}
build() {
cd "PrismLauncher"
mkdir -p build
cd build
cmake -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DLauncher_BUILD_PLATFORM="debian" \
-DLauncher_APP_BINARY_NAME="${_pkgname}" \
-DENABLE_LTO=ON \
-DLauncher_QT_VERSION_MAJOR=5 \
-DBUILD_TESTING=OFF \
..
cmake --build .
}
package() {
cd "PrismLauncher/build"
DESTDIR="$pkgdir" cmake --install .
}