makedeb


prismlauncher-git 5.0.r0.g41032aa-2


Minecraft launcher with ability to manage multiple instances.

Click here to go back to the commit logs for prismlauncher-git.

Commit:


Hash: bf598f7138d574bd5e1e0df54b25a72cfb156b1d

Message: fix: conflict with polymc Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>

Diff


diff --git a/.SRCINFO b/.SRCINFO
index aedf7cf..26ba6df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,7 @@ generated-by = makedeb-makepkg
 pkgbase = prismlauncher-git
 	pkgdesc = Minecraft launcher with ability to manage multiple instances.
 	pkgver = 5.0.r0.g41032aa
-	pkgrel = 1
+	pkgrel = 2
 	url = https://github.com/PrismLauncher/PrismLauncher
 	arch = i686
 	arch = amd64
@@ -28,6 +28,7 @@ pkgbase = prismlauncher-git
 	optdepends = java-runtime=17: support for Minecraft versions >= 1.17
 	provides = prismlauncher
 	conflicts = prismlauncher
+	conflicts = polymc
 	source = git+https://github.com/PrismLauncher/PrismLauncher.git
 	sha256sums = SKIP
 
diff --git a/PKGBUILD b/PKGBUILD
index 5661247..40329ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
 _pkgname=prismlauncher
 pkgname=${_pkgname}-git
 pkgver=5.0.r0.g41032aa
-pkgrel=1
+pkgrel=2
 pkgdesc="Minecraft launcher with ability to manage multiple instances."
 arch=('i686' 'amd64')
 url="https://github.com/PrismLauncher/PrismLauncher"
 license=('GPL3')
 depends=('libqt5xml5' 'libqt5core5a' 'libqt5network5' 'libqt5gui5')
 provides=('prismlauncher')
-conflicts=('prismlauncher')
+conflicts=('prismlauncher' 'polymc')
 makedepends=('extra-cmake-modules' 'g++' 'gcc' 'cmake' 'git' 'openjdk-17-jdk' 'zlib1g-dev' 'libgl1-mesa-dev' 'qtbase5-dev' 'qtchooser' 'qt5-qmake' 'qtbase5-dev-tools')
 optdepends=('java-runtime=8: support for Minecraft versions < 1.17'
             'java-runtime=17: support for Minecraft versions >= 1.17')