makedeb


pirate-get 0.4.2-7


A command line interface for the Pirate Bay

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for pirate-get.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: Marcin (CTRL) Wieczorek (AUR) <marcin@marcin.co>
# Contributor: Viktor Stanchev (AUR) <me aatt viktorstanchev doot com>
# Contributor: Wilson Birney (AUR) <wpbirney@gmail.com>

pkgname=pirate-get
pkgver=0.4.2
pkgrel=7
pkgdesc='A command line interface for the Pirate Bay'
arch=('all')
url='https://github.com/vikstrous/pirate-get/'
license=('AGPL')
depends=('python3-veryprettytable' 'python3-bs4' 'python3-termcolor' 'python3-colorama' 'python3-pyperclip')
makedepends=('python3-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/vikstrous/pirate-get/archive/${pkgver}.tar.gz")
b2sums=('191f8ea3e8f2df94163372a4b2225345b4bded1cfa1a6886db1657e509b23f0ddcc328a3c23c4c9e47c2ba21388a20b5e275935a5c7cdff6d5abc063a29c9325')

build() {
	cd "${srcdir}/${pkgname}-${pkgver}"
	python3 setup.py build
}

package() {
	cd "${srcdir}/${pkgname}-${pkgver}"
	python3 setup.py install --root "${pkgdir}" --optimize=1 --skip-build --install-layout deb

	rm -Rf "$pkgdir/usr/lib/python3/dist-packages/tests"

	install -Dm644 "LICENSE" "$pkgdir/usr/share/doc/$pkgname/license"
	install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/readme"
}