makedeb


owlink-git 1.8e4e840-1


An open Apple Wireless Direct Link (AWDL) implementation written in C

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for owlink-git.

# Maintainer: Jomar Milan <jomarm@jomarm.tech>

pkgname=owlink-git
pkgver=1.8e4e840
pkgrel=1
pkgdesc='An open Apple Wireless Direct Link (AWDL) implementation written in C'
arch=('any')
url='https://owlink.org'
license=('GPL-3.0 License')
makedepends=('cmake' 'git' 'ninja-build' 'libpcap-dev' 'libev-dev' 'libnl-3-dev' 'libnl-genl-3-dev' 'libnl-route-3-dev')
depends=('libpcap0.8' 'libev4' 'libnl-3-200')
source=('git+https://github.com/seemoo-lab/owl.git')
sha256sums=('SKIP')

pkgver() {
	cd "$srcdir/owl"
	printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

prepare() {
	cd "$srcdir/owl"
	git submodule update --init
}

build() {
	cd "$srcdir/owl"
	cmake -DCMAKE_BUILD_TYPE=Release -B build -G Ninja
	ninja -C build
}

package() {
	DESTDIR="$pkgdir" ninja -C "$srcdir/owl/build" install
}