makedeb


nwg-wrapper 0.1.2-1


Wrapper to display a script output or a text file content on the desktop in sway or other wlroots-based compositors

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for nwg-wrapper.

# Maintainer: Cristóbal Tapia <crtapia at gmail dot com>
# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('nwg-wrapper')
pkgver=0.1.2
pkgrel=1
pkgdesc="Wrapper to display a script output or a text file content on the desktop in sway or other wlroots-based compositors"
arch=('x86_64')
url="https://github.com/nwg-piotr/nwg-wrapper"
license=('MIT')
depends=('python3' 'python3-i3ipc' 'libgtk-layer-shell-dev' 'libgtk-layer-shell0')
makedepends=('python-setuptools' 'python3-wheel')
optdepends=('wlr-randr: for non-sway Wayland WMs support')
source=("$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/"$pkgname"/archive/v"$pkgver".tar.gz")

md5sums=('a2211523b90feefaa3fe6599cb495549')

package() {
  cd "${pkgname}-${pkgver}"
  python3 setup.py install --root="${pkgdir}" --optimize=1
}