makedeb


nushell-bin 0.99.1-1


A new type of shell

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for nushell-bin.

# Maintainer: Zhongmin Lin <zhongmin.lin3@gmail.com>
pkgname=nushell-bin
pkgver=0.99.1
pkgrel=1
pkgdesc="A new type of shell"
arch=('amd64' 'aarch64')
url="https://www.nushell.sh"
license=('MIT')
# depends=()
provides=('nu')
conflicts=('nu')
source_amd64=("nu-${pkgver}-linux-x86_64.tar.gz::https://github.com/nushell/nushell/releases/download/${pkgver}/nu-${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
source_aarch64=("nu-${pkgver}-linux-aarch64.tar.gz::https://github.com/nushell/nushell/releases/download/${pkgver}/nu-${pkgver}-aarch64-unknown-linux-gnu.tar.gz")
sha256sums_amd64=('3aeb6b790414e29296097790074f2e03db29b0aba329306e3ffdbfefa3e2664f')
sha256sums_aarch64=('5e4437a05faf127d91760f86b07e895832bd7afef6db90b8c717bcbc9ecb4299')

package() {
	cd nu-${pkgver}-*-unknown-linux-*
	for f in $(find . -type f -name "nu*"); do
		install -Dm755 "$f" "${pkgdir}/usr/bin/$f"
	done
	install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/nushell/LICENSE"
	install -Dm644 "README.txt" "${pkgdir}/usr/share/doc/nushell/README.txt"
}