makedeb


nushell-bin 0.97.1-1


A new type of shell

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for nushell-bin.

# Maintainer: Zhongmin Lin <zhongmin.lin3@gmail.com>
pkgname=nushell-bin
pkgver=0.97.1
pkgrel=1
pkgdesc="A new type of shell"
arch=('amd64' 'aarch64')
url="https://www.nushell.sh"
license=('MIT')
# depends=()
provides=('nu')
conflicts=('nu')
source_amd64=("nu-${pkgver}-linux-x86_64.tar.gz::https://github.com/nushell/nushell/releases/download/${pkgver}/nu-${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
source_aarch64=("nu-${pkgver}-linux-aarch64.tar.gz::https://github.com/nushell/nushell/releases/download/${pkgver}/nu-${pkgver}-aarch64-unknown-linux-gnu.tar.gz")
sha256sums_amd64=('c093ce7178094541ffd1c9a537bcb4b9eccf1c9f12a454a938f21d8719fb9f79')
sha256sums_aarch64=('2222c9d61c82f73274de06ae8c2fd12a59bf706486336fcd7f00b0ff02ecc1c5')

package() {
	cd nu-${pkgver}-*-unknown-linux-*
	for f in $(find . -type f -name "nu*"); do
		install -Dm755 "$f" "${pkgdir}/usr/bin/$f"
	done
	install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/nushell/LICENSE"
	install -Dm644 "README.txt" "${pkgdir}/usr/share/doc/nushell/README.txt"
}