makedeb


ngrok-bin 3.12.0-1


Introspected tunnels to localhost

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for ngrok-bin.

# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
# vim: set sw=2 expandtab:
#
# URLs obtained from here:
# https://github.com/ngrok/docker-ngrok/blob/main/releases.json
#
pkgname=ngrok-bin
pkgver=3.12.0
pkgrel=1
pkgdesc='Introspected tunnels to localhost'
arch=(amd64 arm arm64 i386)
provides=(ngrok)
conflicts=(ngrok)
url='https://ngrok.com/'

source_amd64=("ngrok-${pkgver}::https://bin.equinox.io/a/6YSL4z8VHmp/ngrok-v3-3.12.0-linux-amd64.zip")
source_arm=("ngrok-${pkgver}::https://bin.equinox.io/a/ddf3TAcgHwA/ngrok-v3-3.12.0-linux-arm.zip")
source_arm64=("ngrok-${pkgver}::https://bin.equinox.io/a/cd9uokauiBV/ngrok-v3-3.12.0-linux-arm64.zip")
source_i386=("ngrok-${pkgver}::https://bin.equinox.io/a/7E9gcxVrwoW/ngrok-v3-3.12.0-linux-386.zip")

sha256sums_amd64=('1d0df17ed955cc67fcad5ddd2d59a95cbd77137106161fda8b976d35d5033184')
sha256sums_arm=('b37d784db3e8533cb0a492be50e0ae74ed47e4a046c8e4fdfa35d2a90691e02f')
sha256sums_arm64=('0786deea90092d713acbad0f87e795faf8587b591bdf65d4d6babee3653db862')
sha256sums_i386=('ef8bb80715a7eb8e03ebb72e8ef4420080ea9908f9fda704827374bad7c4d1db')

package() {
  install -Dm755 "$srcdir/ngrok-${pkgver}" "$pkgdir/usr/bin/ngrok"
}