makedeb


netns-exec 1.aa346fd-1


SetUID program which allows users to run applications in a network namespace.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for netns-exec.

# Maintainer: PWall <34860495+PWall2222@users.noreply.github.com>

pkgname=netns-exec
pkgver=1.aa346fd
pkgrel=1
pkgdesc="SetUID program which allows users to run applications in a network namespace."
arch=('amd64')
url="https://github.com/pekman/netns-exec"
license=('GPL2')
depends=()
source=("git+https://github.com/pekman/netns-exec.git"
		"git+https://git.kernel.org/pub/scm/network/iproute2/iproute2.git")
sha256sums=('SKIP'
			'SKIP')

pkgver() {
	cd "$pkgname"
	printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

build() {
	cd "$pkgname"
	rmdir iproute2 && ln -s ../iproute2 ./
	make
}

package() {
	mkdir -p $pkgdir/usr/bin
	install -Dm4755 $srcdir/$pkgname/netns-exec $pkgdir/usr/bin/
	install -Dm755 $srcdir/$pkgname/netns-exec-dbus $pkgdir/usr/bin/
}