makedeb


namespaced-openvpn-git 1.a3fa42b-1


Wrapper for OpenVPN on Linux solving various privacy issues

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for namespaced-openvpn-git.

# Maintainer: PWall <34860495+PWall2222@users.noreply.github.com>

_pkgname=namespaced-openvpn
pkgname=${_pkgname}-git
pkgver=1.a3fa42b
pkgrel=1
pkgdesc='Wrapper for OpenVPN on Linux solving various privacy issues'
arch=('any')
license=('MIT')
url="https://github.com/slingamn/namespaced-openvpn"
makedepends=(git)
depends=(python3 openvpn)
source=("git+$url.git")
sha256sums=('SKIP')

pkgver() {
	cd ${_pkgname}
	printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

package() {
	mkdir -p "$pkgdir/usr/bin/"
	install -D -m 755 "$srcdir/$_pkgname/$_pkgname" "$pkgdir/usr/bin/"
}