makedeb


mongosh-bin 1:2.2.6-1


MongoDB Shell is the quickest way to connect to (and work with) MongoDB

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for mongosh-bin.

# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
# https://downloads.mongodb.com/compass/mongosh-1.6.0-linux-x64.tgz

pkgname=mongosh-bin
pkgver=2.2.6
pkgrel=1
epoch=1
pkgdesc="MongoDB Shell is the quickest way to connect to (and work with) MongoDB"
arch=(amd64)
url="https://www.mongodb.com/try/download/shell"
license=('Apache')
extensions=('zipman')
source=(
  "https://downloads.mongodb.com/compass/mongosh-$pkgver-linux-x64.tgz"
)
sha256sums=('33670289b862b37722153dd69a9ff917071d3f024036a96512cc0cd9759dad10')

package() {
  cd "mongosh-$pkgver-linux-x64"

  install -D bin/mongosh "$pkgdir/usr/bin/mongosh"
  install -D bin/mongosh_crypt_v1.so "$pkgdir/usr/lib64/mongosh_crypt_v1.so"
  install -D mongosh.1.gz "$pkgdir/usr/share/man/man1/mongosh.1.gz"
}