makedeb


monero-gui 0.18.1.2-1


QT GUI wallet for Monero: the secure, private, untraceable peer-to-peer currency

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for monero-gui.

# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>

pkgname='monero-gui'
_gitname='monero-gui'
provides=('monero-gui')
pkgver='0.18.1.2'
pkgrel='1'
pkgdesc="QT GUI wallet for Monero: the secure, private, untraceable peer-to-peer currency"
arch=('x86_64')
license=('BSD')
url='https://www.getmonero.org'
makedepends=('git' 'build-essential' 'cmake')
depends=('miniupnpc' 'libunbound-dev' 'graphviz' 'doxygen' 'libunwind8-dev' 'pkg-config' 'libssl-dev' 'libzmq3-dev' 'libsodium-dev' 'libhidapi-dev' 'libnorm-dev' 'libusb-1.0-0-dev' 'libpgm-dev' 'libprotobuf-dev' 'protobuf-compiler' 'libgcrypt20-dev' 'libboost-chrono-dev' 'libboost-date-time-dev' 'libboost-filesystem-dev' 'libboost-locale-dev' 'libboost-program-options-dev' 'libboost-regex-dev' 'libboost-serialization-dev' 'libboost-system-dev' 'libboost-thread-dev' 'qtbase5-dev' 'qt5-default' 'qtdeclarative5-dev' 'qml-module-qtqml-models2' 'qml-module-qtquick-controls' 'qml-module-qtquick-controls2' 'qml-module-qtquick-dialogs' 'qml-module-qtquick-xmllistmodel' 'qml-module-qt-labs-settings' 'qml-module-qt-labs-platform' 'qml-module-qt-labs-folderlistmodel' 'qttools5-dev-tools' 'qml-module-qtquick-templates2' 'libqt5svg5-dev' 'qtmultimedia5-dev' 'qml-module-qtmultimedia')
source=("git+https://github.com/monero-project/monero-gui.git#tag=v${pkgver}"
		"monero-gui.desktop")
conflicts=("${_gitname}-git" "${_gitname}-bin")
b2sums=('SKIP'
		'a399e2e348ce396072172a57a220c76664167f32ac16e130a6ad1b355ad0cdb8b035adff1f4191df8c711ff4c648e3e3f3d830aba72ed9596bfe6289c2b9e727')

prepare() {
    cd "${_gitname}"
    git submodule update --init --recursive
}

build() {
    cd "${_gitname}"
    make release
}

package() {
	# install binaries
	install -Dm755 "${_gitname}/build/release/bin/monero-wallet-gui" -t "${pkgdir}/usr/bin"
	# install desktop entry
	install -Dm644 "monero-gui.desktop" "${pkgdir}/usr/share/applications/monero-gui.desktop"
    install -Dm644 "${_gitname}/images/monero-vector.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/monero.svg"
}