makedeb


mist-bin 0.12.0-55


The official command-line interface for the makedeb Package Repository

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for mist-bin.

# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=mist-bin
pkgver=0.12.0
pkgrel=55
pkgdesc='The official command-line interface for the makedeb Package Repository'
arch=('any')
depends=(
    'libapt-pkg-dev'
    'libssl-dev'
    'sudo'
)
optdepends=(
    'r!less'
)
conflicts=('mist')
provides=("mist=${pkgver}")
license=('GPL3')
url='https://github.com/makedeb/mist'
control_fields=('MPR-Package: yes')

_source_uri="https://proget.makedeb.org/debian-feeds/prebuilt-mpr/${MAKEDEB_DISTRO_CODENAME}/mist/amd64/mist_amd64_${pkgver}-1.deb"
focal_source=("${_source_uri}")
jammy_source=("${_source_uri}")
bullseye_source=("${_source_uri}")

focal_sha512sums=('c4956ccca5bd6be497a8ac994d51b36454c575a21c3ff23378bc3d87e5235d9a7e9a00501d4f98fe49f963b0554b7696cd88fee00201c74eca90688efde53b2c')
jammy_sha512sums=('a9fa348ad4184f296a94a3e09f98ee7f19472e8fef29e0edeee854e26a77a0c26f4cfd27ad0a4acee436ef3f02e95fa92717df495f4d8016dc22779d1917609b')
bullseye_sha512sums=('233b7d2b9c8a4373cfc955bf34dc9ab175bf357b71d1f05d2cfd55560cc4af55cb2fa1781e3623db2ede7ba0bfd972728ec6da6b38fcdec18945bc9cf6bf9d28')

# Any distro not covered by the above can't install the package, so just fail.
source=('https://example.invalid')
sha512sums=('SKIP')

package() {
    tar xf data.tar.gz -C "${pkgdir}"
    tar xf control.tar.gz
    postinst=src/postinst
}

# vim: set sw=4 expandtab: