makedeb


miniserve-bin 0.26.0-1


miniserve is a small, self-contained cross-platform CLI tool that allows you to just grab the binary and serve some file(s) via HTTP

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for miniserve-bin.

# Maintainer: Edgar <Edgar{at}AnotherFoxGuy.com>

pkgname=miniserve-bin
pkgver=0.26.0
pkgrel=1
pkgdesc='miniserve is a small, self-contained cross-platform CLI tool that allows you to just grab the binary and serve some file(s) via HTTP'
url="https://github.com/svenstaro/miniserve"
license=('MIT')
provides=("miniserve")
conflicts=("miniserve")
options=("!strip")
arch=('amd64' 'aarch64')
_filename="miniserve-v${pkgver}-${arch}"

source_aarch64=("${_filename}::${url}/releases/download/v${pkgver}/miniserve-${pkgver}-aarch64-unknown-linux-musl")
source_amd64=("${_filename}::${url}/releases/download/v${pkgver}/miniserve-${pkgver}-x86_64-unknown-linux-musl")

sha256sums_amd64=('b26238e9f40f54e565ed472be331b750abb357536d359dbcc2d411a4a37f8ebb')
sha256sums_aarch64=('b26238e9f40f54e565ed472be331b750abb357536d359dbcc2d411a4a37f8ebb')

package() {
    install -Dm755 "${srcdir}/${_filename}" "${pkgdir}/usr/bin/miniserve"
}