makedeb


melonds-bin 0.9.5-1


DS emulator, sorta

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for melonds-bin.

# Maintainer: hiddeninthesand <hiddeninthesand at protonmail dot com>

pkgname='melonds-bin'
_gitname='melonds'
provides=('melonds')
pkgver='0.9.5'
pkgrel='1'
pkgdesc="DS emulator, sorta"
arch=('x86_64')
depends=('libcurl4-gnutls-dev' 'libpcap0.8-dev' 'libsdl2-dev' 'qt5-default' 'libslirp-dev' 'libarchive-dev' 'libepoxy-dev')
license=('GPL3')
url="https://github.com/Arisotura/${_gitname}"
conflicts=("${_gitname}-git" "${_gitname}")

source=("melonDS"::"${url}/releases/download/${pkgver}/melonDS_${pkgver}_linux_x64.zip"
        "git+${url}.git#tag=${pkgver}")
b2sums=('e5c0930bb60c640560b925fcc6efbd34dcbb7ea831b2d71aadcedc96714f8fd27378d191af4ac28288533538846a5a4925bd9b90b07fd076b5187e0f18600168'
        'SKIP')

package() {
    cd "${srcdir}"
    install -Dm755 "melonDS" "${pkgdir}/usr/bin/melonDS"

    for size in 16 32 64 128 256; do
        install -Dm644 "${_gitname}/res/icon/melon_${size}x${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/melonDS.png"
    done
    sed "s/net.kuribo64.melonDS/melonDS/" -i "${_gitname}/res/net.kuribo64.melonDS.desktop"
    install -Dm644 "${_gitname}/res/net.kuribo64.melonDS.desktop" "${pkgdir}/usr/share/applications/melonDS.desktop"
}