makedeb


libnss-mysql 1.7.1-2


A fork from http://libnss-mysql.sourceforge.net/

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for libnss-mysql.

# Maintainer: Cann1Bunny c1b@c1b.io
pkgname=libnss-mysql
pkgver=1.7.1
pkgrel=2
pkgdesc='A fork from http://libnss-mysql.sourceforge.net/'
arch=('amd64' 'arm64')
url='https://github.com/saknopper/libnss-mysql'
license=('GPL-2.0')
makedepends=('libmariadb-dev')
source=('https://github.com/saknopper/libnss-mysql/releases/download/v1.7.1/libnss-mysql-1.7.1.tar.gz')
b2sums=('bf3a83a5f50b0979bd189bd9a6068c4899991c5c7c78b3725d610b40570007c8a9e2f99f63c66d7807fdad6b7c6bae9fd277e6bec5163ab42bced31f8e9a1d09')

build() {
  cd "${pkgname}-${pkgver}"
  ./configure --prefix=''
  make
}

check() {
  cd "${pkgname}-${pkgver}"
  make -k check
}

package() {
  cd "${pkgname}-${pkgver}"
  make DESTDIR="$pkgdir/" install
}