makedeb


libirecovery 1.0.0-1


Library and utility to talk to iBoot/iBSS via USB

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for libirecovery.

# Maintainer: Leo Puvilland <lpuvilla0001@mymail.lausd.net>

pkgname=libirecovery
pkgver=1.0.0
pkgrel=1
pkgdesc="Library and utility to talk to iBoot/iBSS via USB"
arch=('x86_64')
url="https://www.libimobiledevice.org/"
license=('LGPL2.1')
depends=('libusb-1.0-0' 'libusb-1.0-0-dev' 'libreadline8' 'libreadline-dev')
source=("https://github.com/libimobiledevice/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2")
sha256sums=('cda0aba10a5b6fc2e1d83946b009e3e64d0be36912a986e35ad6d34b504ad9b4')

build() {
  cd "$pkgname-$pkgver"

  ./configure --prefix=/usr
  make
}

package() {
  cd "$pkgname-$pkgver"

  make DESTDIR="$pkgdir" install
}