makedeb
Library with common code used by the libraries and tools around the libimobiledevice project
Viewing /PKGBUILD
.
Click here to go back to the Git tree for libimobiledevice-glue-git.
# Maintainer: Leo Puvilland <lpuvilla0001@mymail.lausd.net>
pkgname=libimobiledevice-glue-git
pkgver=1.19.499a557
pkgrel=1
pkgdesc='Library with common code used by the libraries and tools around the libimobiledevice project'
url='http://www.libimobiledevice.org/'
arch=(x86_64)
license=('LGPL2.1')
makedepends=('libplist-git' 'git')
source=("git+https://github.com/libimobiledevice/libimobiledevice-glue")
sha256sums=('SKIP')
pkgver() {
cd libimobiledevice-glue
printf "1.%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd libimobiledevice-glue
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd libimobiledevice-glue
./configure --prefix=/usr
make
}
package() {
cd libimobiledevice-glue
make DESTDIR="$pkgdir" install
}