makedeb


libimobiledevice-git 1:1.3.0.r73.gb3d35fb-1


Library that talks the protocols to support iPhone and iPod Touch devices on Linux

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for libimobiledevice-git.

# Maintainer: Leo Puvilland <lpuvilla0001@mymail.lausd.net>
pkgname=libimobiledevice-git
epoch=1
pkgver=1.3.0.r73.gb3d35fb
pkgrel=1
pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
url="http://www.libimobiledevice.org/"
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
depends=('build-essential' 'checkinstall' 'git' 'autoconf' 'automake' 'libtool-bin' 'libplist-git' 'libusbmuxd-git' 'libssl-dev' 'usbmuxd' 'pkg-config')
makedepends=('python' 'python-dev' 'cython3' 'libplist-git' 'autoconf-archive'
             'git' 'python-setuptools')
provides=('libiphone-git' 'libiphone' 'libimobiledevice')
conflicts=('libiphone-git' 'libiphone' 'libimobiledevice')
source=("git+https://github.com/libimobiledevice/libimobiledevice")
sha256sums=('SKIP')

pkgver() {
	cd libimobiledevice
	git describe --long --tags | sed 's/-/.r/;s/-/./'
}

prepare() {
	cd libimobiledevice
	NOCONFIGURE=1 ./autogen.sh
}

build() {
	cd libimobiledevice
	./configure --prefix=/usr
	make
}

package() {
	cd libimobiledevice
	make DESTDIR="$pkgdir" install
}