makedeb


libdpkg-shlibdeps-resolve-perl 4.6.2-1


Library for resolving shared library dependencies for dpkg-based systems

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for libdpkg-shlibdeps-resolve-perl.

# Maintainer: huakim-tyk <zuhhaga@gmail.com>
pkgname='libdpkg-shlibdeps-resolve-perl'
pkgver='4.6.2'
pkgrel='1'
pkgdesc="Library for resolving shared library dependencies for dpkg-based systems"
arch=('all')
license=('PerlArtistic' 'GPL')
depends=(
'libalgorithm-loops-perl'
'libdpkg-parse-perl'
'libdpkg-perl'
'libscalar-list-utils-perl'
'perl'
)
makedepends=(
'coreutils'
'findutils'
'make'
)
checkdepends=()
url='https://metacpan.org/release/Moose'
_distdir='DPKG-ShlibDeps-Resolve'
source=("git+https://github.com/huakim-tyk/${_distdir}.git")
sha512sums=('SKIP')

build() {
  export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                      \
         PERL_AUTOINSTALL=--skipdeps                            \
         PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'"     \
         PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
         MODULEBUILDRC=/dev/null

  cd "$srcdir/$_distdir"
  /usr/bin/perl Makefile.PL
  make
}

package() {
  cd "$srcdir/$_distdir"
  make install

  find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}