makedeb
A simple terminal UI for git commands, written in Go with the gocui library
Viewing /PKGBUILD
.
Click here to go back to the Git tree for lazygit-bin.
# Maintainer: Edgar <Edgar{at}AnotherFoxGuy.com>
pkgname=lazygit-bin
pkgver=0.42.0
pkgrel=1
pkgdesc='A simple terminal UI for git commands, written in Go with the gocui library'
url="https://github.com/jesseduffield/lazygit"
license=('MIT')
provides=("lazygit")
conflicts=("lazygit")
arch=('aarch64' 'armv6h' 'i686' 'amd64')
source_aarch64=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_arm64.tar.gz")
source_armv6h=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_armv6.tar.gz")
source_i686=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_32-bit.tar.gz")
source_amd64=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_x86_64.tar.gz")
sha256sums_aarch64=('f3e40f46cbf649beaea94859f41499c83efac2db7877b5c02f6c938fae3049c3')
sha256sums_armv6h=('eff22ffb76522d7158abb3587bd3a3e6cc445c617f2f47185364901721f10f52')
sha256sums_i686=('dcba25fd947dddda810826b11d4237e6c66c3ea6eb3c412863be291cafa0ed0c')
sha256sums_amd64=('c3f8f1630fa9a0a00b68425c95879e059a42158425fd720b0b303e101d347d57')
package() {
install -Dm755 "${srcdir}/lazygit" "${pkgdir}/usr/bin/lazygit"
}