makedeb


just 1.25.2-1


Just a command runner

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for just.

# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=just
pkgver=1.25.2
pkgrel=1
pkgdesc='Just a command runner'
arch=('any')
makedepends=('cargo>=1.63')
license=('CC0-1.0')
url='https://just.systems'

source=("https://github.com/casey/just/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('SKIP')

build() {
    cd "${pkgname}-${pkgver}/"
    cargo build --release
}

package() {
    cd "${pkgname}-${pkgver}/"
    install -Dm 755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
    install -Dm 644 "completions/${pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/just"
    install -Dm 644 "man/${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
}

# vim: set sw=4 expandtab: